AWS Outage Impacting Support Services

Incident Report for PracticeQ

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 17:07 EDT

Monitoring

We wanted to let you know that due to a widespread AWS outage on the East Coast, our support CRM is currently down.
This means our team can’t view or respond to new support tickets at the moment. We know how important timely support is and truly appreciate your patience while AWS works to resolve the issue.

Our platform and core services remain fully operational — this only affects our ability to see and respond to support requests.

We’ll post an update here as soon as ticket visibility is restored.
Thank you for your understanding and patience — we’re standing by to jump right back in as soon as everything is back online.

— The IntakeQ/PracticeQ Team
Posted Oct 20, 2025 - 12:38 EDT
This incident affected: External Services (Email Service).