Issue with PracticeQ Payments

Incident Report for PracticeQ

Resolved

Service has returned to normal and we are monitoring for further issues.
Posted Sep 26, 2025 - 19:37 EDT

Identified

We have identified an issue that NMI Payment Gateway is currently experiencing that is affecting our ability to process and accept payments. We will resolve this incident once we have received confirmation from NMI that the issue has been resolved.
Posted Sep 26, 2025 - 17:56 EDT
This incident affected: Application Service.