Intermittent slowness issue under investigation

Incident Report for PracticeQ

Resolved

The issue has now been resolved. Thank you for your patience as we worked to quickly resolve the issue.
Posted Nov 11, 2025 - 16:55 EST

Identified

The issue has now been identified and a resolution being implemented
Posted Nov 11, 2025 - 16:26 EST

Investigating

We are currently investigating an issue causing slowness for some customers. We anticipate a resolution shortly.
Posted Nov 11, 2025 - 16:19 EST
This incident affected: Application Service.